Jump to content
Sign in to follow this  
sausage450r

Fix for leaky suzuki/kawi petcocks

Recommended Posts

I just acquired another lt50 and from past experiences with lt80’s and my other lt50. The stock fuel petcock.   Sucks! Suzuki uses a vacuum operated petcock (poppet valve) rather than a traditional on/off. The way the system works is; a line runs to the carb and another runs to the intake elbow, vacuum from the motor  pulls the poppet valve open allowing gas to flow. Well as everyone in cali knows are fuel destroys these systems within a month of being idle. Smelling up your garage and toyhauler with fuel. the design is a solution in search of a problem. Im sure some suzuki engineer claims this as his pride and glory.  Effing get rid of it!

the stock vacuum petcock runs 110$ from suzuki and is always a back order item. A factory carbureted yamaha raptor(quality) petcock is 32$ at your local dealer and is an exact bolt in match for both the lt50/80 and now you have an on/off. Cut a section of fuel line and plug (i used stainless steel round head rivet) the intake inlet. Now route your fuel line to carb the same as before. No more smell or stains in your toyhauler/garage. 

BF5B254C-3376-408D-A372-CE2C632FED6D.jpeg

59FA05D9-8D75-45CF-885C-A2DC3ECF47A9.jpeg

Edited by sausage450r

Share this post


Link to post
Share on other sites

GREAT Post / We did it on the LT80 too...…..the stock factory set up is a nightmare!!!!

:poule:

Share this post


Link to post
Share on other sites

Also works on first gen z400/kfx400’s. 

Share this post


Link to post
Share on other sites

I just picked up a z400 not long ago and was trippin on the no "off" wtf?! This makes sense. Good stuff mang! 

Share this post


Link to post
Share on other sites

Do you know if I can use the same Raptor petcock for an LTZ250?

Had that probelm on my lt50 and LTZ250. Replaced both. I used an aftermarket one for the lt50 but an OEM one for the LTZ250. 

Just in case it effs up, I could hopefully use the Raptor petcock. 

 

Share this post


Link to post
Share on other sites
On 12/29/2018 at 6:17 AM, sinverguenza said:

Do you know if I can use the same Raptor petcock for an LTZ250?

Had that probelm on my lt50 and LTZ250. Replaced both. I used an aftermarket one for the lt50 but an OEM one for the LTZ250. 

Just in case it effs up, I could hopefully use the Raptor petcock. 

 

I do believe they are all basically the same flange/bolt pattern

Share this post


Link to post
Share on other sites
10 hours ago, sausage450r said:

I do believe they are all basically the same flange/bolt pattern

Great! Thanks!

Share this post


Link to post
Share on other sites

I just replaced the one on my kids 80 with one from an LT160 the hose barb was the same as the 80. I have the stock vacuum one if anyone needs it. I just replaced it before the inevitable. 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Preview Post
Sign in to follow this  

More Links

©2001 GlamisDunes.com.
All rights reserved.

×
×
  • Create New...