Jump to content
sinverguenza

*Fixed*2003 F250 Mirror Upgrade Wire Problem

Recommended Posts

Posted (edited)

I bought some new left and right mirrors with the lights. I have viewed several YouTube videos and wrote down which wires do what. I have searched several forums.

Still can't find the correct color wires for the front turn signals.

I found the rear but when you step on the brake it activates the turn signal. I don't want that 

This is what I read or watched:

White- right turn = wrong

Green- left turn = wrong

Orange w/blue stripe is rear (don't want)

Light green w/orange stripe is rear (don't want that).

Green w/ white stripe left turn YouTube =but can't find it

White w/ blue stripe right turn YouTube= but can't find.

Youtube video review of this same brand which I bought stated they sent him a diagram. I did not receive a diagram.Will have to contact the mirror company tomorrow and hopefully they can tell me. 

 

Hopefully someone here knows so I can finish this today. 

Thanks!!!

Edited by sinverguenza

Share this post


Link to post
Share on other sites

Check the mirror company website for the installation manual or the wiring diagram. A lot of times it's on their website, or someone has scanned it in and uploaded it.

Share this post


Link to post
Share on other sites
Posted (edited)

Can you tell what color wire goes into the signal up front at the bulb?  If you can't find it in the harness you could always run a wire back to the cab from the front signals.

~jw

Edited by jwest2sh

Share this post


Link to post
Share on other sites

You can use a test light to probe the wires. 

Share this post


Link to post
Share on other sites
2 hours ago, socaldmax said:

Check the mirror company website for the installation manual or the wiring diagram. A lot of times it's on their website, or someone has scanned it in and uploaded it.

Didn't think of checking website since I thought I'd call them.

 

46 minutes ago, jwest2sh said:

Can you tell what color wire goes into the signal up front at the bulb?  If you can't find it in the harness you could always run a wire back to the cab from the front signals.

~jw

Both batteries are in the way. 

 

38 minutes ago, 310kick said:

You can use a test light to probe the wires. 

Used test light and a lot of poked wires and fingers. Nothing. Checked all the wires coming from steering column or at least I think I did.

Share this post


Link to post
Share on other sites
1 hour ago, sinverguenza said:

Didn't think of checking website since I thought I'd call them.

 

Both batteries are in the way. 

 

Used test light and a lot of poked wires and fingers. Nothing. Checked all the wires coming from steering column or at least I think I did.

The turn signals on mine came out pretty easy...I think it was only two bolts.  I'm guessing the wire color doesn't change from the bulb to the harness? I could be wrong though, Ford has been known to do some wierd stuff with wireing.  Let us know what you find out...I want to do the same conversion to mine eventually.

~jw

Share this post


Link to post
Share on other sites

Just googled how to remove front turn signal bulb which is super easy. Should of thought of that earlier.  Could have saved myself some poked finger tips.

Will try tomorrow after calling the company. 

Keep watching different videos and almost all claim to use the white with blue stripe wire. 

Will have to look again. 

Share this post


Link to post
Share on other sites
2 minutes ago, jwest2sh said:

The turn signals on mine came out pretty easy...I think it was only two bolts.  I'm guessing the wire color doesn't change from the bulb to the harness? I could be wrong though, Ford has been known to do some wierd stuff with wireing.  Let us know what you find out...I want to do the same conversion to mine eventually.

~jw

https://www.ebay.com/itm/for-99-07-Ford-F250-F550-SuperDuty-Towing-Mirrors-Pair-Power-Heated-Amber-Signal-/392077447210?txnId=889468938026

 

This where I got mine from. Had to trim some little plastic nubs with a hacksaw. Took like 1 minute to do. 

 

Now, only if I can find the turn signal wires. 

Watched a video on to remove the turn signals and it looks easy. Should have thought about that earlier. 

Share this post


Link to post
Share on other sites
1 minute ago, sinverguenza said:

https://www.ebay.com/itm/for-99-07-Ford-F250-F550-SuperDuty-Towing-Mirrors-Pair-Power-Heated-Amber-Signal-/392077447210?txnId=889468938026

 

This where I got mine from. Had to trim some little plastic nubs with a hacksaw. Took like 1 minute to do. 

 

Now, only if I can find the turn signal wires. 

Watched a video on to remove the turn signals and it looks easy. Should have thought about that earlier. 

Those are nice.  Post up some pics when you get it done.  I wonder if there is some kind of adapter pigtail or something?  There are a ton of guys doing the swap...would be a pretty common item.

~jw

Share this post


Link to post
Share on other sites
35 minutes ago, jwest2sh said:

No since it's just to convert old plug to newer plug. The mirrors I bought actually come with the plug but mine didn't need it.

I have to look at it again tomorrow. I would take a break and come back to it after a lil drink. But haven't found the wires. 

Share this post


Link to post
Share on other sites
Just now, sinverguenza said:

No since it's just to convert old plug to newer plug. The mirrors I bought actually come with the plug but mine didn't need it.

I have to look at it again tomorrow. I would take a break and come back to it after a lil drink. But haven't found the wires. 

OK...i've been looking around online too but haven't found anything yet.

 

~jw

Share this post


Link to post
Share on other sites
55 minutes ago, jwest2sh said:

OK...i've been looking around online too but haven't found anything yet.

 

~jw

Thanks! Hopefully tomorrow the company can tell me which wires and hopefully it's something different then what I have been looking for. If not will take out the turn signal housing up front and look.

Share this post


Link to post
Share on other sites
2 hours ago, jwest2sh said:

i have these mirrors and they were direct plug play bolt on, came with pig tails and all. most trucks are prewired for all the fancy stuff regardless of if they come with it. makes for 1 harness vs. 1 for each trim level

Share this post


Link to post
Share on other sites
43 minutes ago, sausage450r said:

i have these mirrors and they were direct plug play bolt on, came with pig tails and all. most trucks are prewired for all the fancy stuff regardless of if they come with it. makes for 1 harness vs. 1 for each trim level

What year truck do you have? I had to make a new ground since running light didn't work.  Powered mirror was plug and play but that's it.

Share this post


Link to post
Share on other sites

I contacted the company and they said they would have a response within 24 hours.  Well that didn't help since I wanna do it now.

Decided to remove front turn signal assembly to look at wires. Wires are soo dirty that the wire looks like a light green with white stripe.

 

I probed again this time had my hazards on just in case I hit a the left or the right. I keep finding the rear turn signals. I can see which wires I had already probed but decided to check those again. FAILED AGAIN!!!!

Decided to run wires to the front turn signals. As of now the running light is the bottom light and turn would be top light in the mirror. 

 

Will continue this nonsense hopefully in the weekend. 

Share this post


Link to post
Share on other sites
3 hours ago, sinverguenza said:

I contacted the company and they said they would have a response within 24 hours.  Well that didn't help since I wanna do it now.

Decided to remove front turn signal assembly to look at wires. Wires are soo dirty that the wire looks like a light green with white stripe.

 

I probed again this time had my hazards on just in case I hit a the left or the right. I keep finding the rear turn signals. I can see which wires I had already probed but decided to check those again. FAILED AGAIN!!!!

Decided to run wires to the front turn signals. As of now the running light is the bottom light and turn would be top light in the mirror. 

 

Will continue this nonsense hopefully in the weekend. 

That's how I did my cab lights on the roof.  I ran a wire to the front parking light and wrapped it in loom.  It looks factory.  I don't like tapping in to the main harness under the dash if I can help it.  It's easier to fix if I F' it up by the front lights.  

~jw

Share this post


Link to post
Share on other sites

So I got it done. Ran wire to each front turn signal. Was waaaaay easier this way. Didn't have a any wire loom but will get some once I button everything back up.

Will take picture once it's dark.

Share this post


Link to post
Share on other sites

When I was taking the picture to post, I noticed that the running light which I changed it to be the top light, is only visible from the side or rear.

I turned on the turn signal and that is visible from the front, side , and rear.

 

Company states that the bottom is the running light but I wanted the bottom to be the turn signal. I'm gonna remove the lens and pop off whatever is blocking the light from shining forward. 

 

Other the all my mishaps they look great.

 

Can't upload picture for some reason.

Share this post


Link to post
Share on other sites
2 minutes ago, sinverguenza said:

When I was taking the picture to post, I noticed that the running light which I changed it to be the top light, is only visible from the side or rear.

I turned on the turn signal and that is visible from the front, side , and rear.

 

Company states that the bottom is the running light but I wanted the bottom to be the turn signal. I'm gonna remove the lens and pop off whatever is blocking the light from shining forward. 

 

Other the all my mishaps they look great.

 

Can't upload picture for some reason.

Good deal.  Glad you got it worked out.  I have been having issues uploading from my pc also....my phone worked fine for some reason?

~jw

Share this post


Link to post
Share on other sites

Picture?

Share this post


Link to post
Share on other sites

100 % of the time I use my phone and have never has a problem uploading a picture until yesterday. Let me try again.

Weird it didn't let me but I was able to load a screen shot of the error message.

Screenshot_20190312-071345_Chrome.jpg

Share this post


Link to post
Share on other sites

So I decided to pop off the lens so that I can switch the bulb assembly. Well it wasn't as easy as switching bottom to top.  One harness has two tabs and the other has 3 tabs. So I had to splice the wire. 

I had already put on the door panels and kick panels so it was easier to splice the wires at the harness.

 

Looks good and happy with the results. My finger not to happy since it was probed/ several million times.

 

Funny how I can't upload picture but a screen shot of the picture uploads.

Screenshot_20190312-195029_Gallery.jpg

Share this post


Link to post
Share on other sites

Looks good! :td:

 

~jw

Share this post


Link to post
Share on other sites
1 hour ago, jwest2sh said:

Looks good! :td:

 

~jw

Gracias!!!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

More Links

©2001 GlamisDunes.com.
All rights reserved.

×

Important Information

By using this site, you agree to our Terms of Use.