Jump to content

Recommended Posts

Hello I changed out the rollers and replaced the belt. Now the quad is stuck in gear. It will not roll freely. Scratching my head over this. 
thanks in advance fellow duners

Share this post


Link to post
Share on other sites

Belt....or Chain ?

Share this post


Link to post
Share on other sites

If the insides of the sheave have ridges, groves or the roller slots are worn badly and allow the rollers cock at an angle, the rollers will hang up.  

No grease and no water in clutch.  

Get crazy and take out 2 rollers and the clutch will engage at a higher RPM for better off the line performance.  

Just sayin.  

Share this post


Link to post
Share on other sites

Did you over-torque the nut on the clutch?

when it comes to lt80 matters, there is  no one better than jack moore in Pennsylvania. He is on atvconnection forums as “lt80”

Edited by sausage450r

Share this post


Link to post
Share on other sites

Presidents Weekend is around the corner, tick tock, tick tock...

Share this post


Link to post
Share on other sites
2 hours ago, sausage450r said:

Did you over-torque the nut on the clutch?

when it comes to lt80 matters, there is  no one better than jack moore in Pennsylvania. He is on atvconnection forums as “lt80”

What he said

Share this post


Link to post
Share on other sites

Just push it over into the corner and worry about it after you install that HRC kit.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Preview Post

More Links

©2001 GlamisDunes.com.
All rights reserved.

×
×
  • Create New...